L-MOUNT Forum

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

Can't update firmware for Lumix 50mm f1.8 lens

PJD

Member
I received my new S5iiX camera (with Lumix 20-60mm zoom and 50mm f1.8 lenses) yesterday, and everything appears to be working as expected, except the camera won't update the firmware for the 50mm f1.8 lens.

I first updated the camera to the new firmware v2.0 via an SD card. That worked fine. The 20-60mm lens already had firmware v1.1 installed, so it didn't require updating.

The 50mm lens has firmware v1.0 installed, and v1.1 is available on Panasonic's website. As instructed, I put the firmware ".plf" file on the SD card's root level. But when I try to update the firmware for the 50mm lens (via an SD card) I get error "File for firmware update cannot be found." Anyone else seen this?

To troubleshoot the problem, I double & triple checked I'd downloaded the correct v1.1 firmware for the lens (and downloaded it more than once), I reformatted and used multiple SD cards (formatted in-camera) to copy the firmware onto, tried using both of the camera's card slots, power-cycled the camera multiple times, unmounted & remounted the lens ... but still get the same error. The fact that the camera v2.0 firmware update process worked correctly makes me wonder if maybe Panasonic has a corrupted copy of the lens v1.1 firmware on their server? Far-fetched, but weirder things have happened.

I plan to contact Panasonic tech support on Monday, but if anyone has suggestions of other things to try, I'd appreciate it.

Again, the cam & lenses appear to work fine, so I can still use them to shoot with, but it would be good to know what the fix is for the error. Cheers.
 
Back
Top